集团旗下网站: 迈领人才网 | 奇酷方舟 | 红砖升本
全国咨询热线:400-807-8991
您现在所在的位置:首页 >关于奇酷 > 行业动态 > 太难啦!Java17以下不能用啦,我们怎么办?

太难啦!Java17以下不能用啦,我们怎么办?

来源:奇酷教育 发表于:

太难啦!Java17以下不能用啦,我们怎么办?

  最近总有学员问:
 
  “Java17以下不能用啦,我们怎么办?”
 
  稳住,问题不大
 
  自Java8版本发布以来,其后的每次更新,都会有小伙伴高呼:Java 8 YYDS!
 
  SpringBoot官宣,正式弃用 Java 8, 最低要求 Java 17。
 
  Java最低版本的支持从8提升到了17。
 
  稳住,
 
  问题不大……
 
  Java17正式发布,新版本提供了不少新特性和功能增强。
 
  不过对于大多数项目而言,往往需要更改代码才能利用到这些新变化,但性能除外 —— 开发者只需要升级 JDK 版本,就能免费获得性能提升。
 
  Spring Boot 可帮助开发人员创建可以运行的、独立的、生产级的基于 Spring 的应用程序。大多数 Spring Boot 应用程序只需要很少的 Spring 配置。
 
  详情信息可以参考[Spring Boot官方文档]
 
  (https://docs.spring.io/spring-boot/docs/3.0.0-M1/reference/html/getting-started.html#getting-started)

 
  Java 17 将成为未来的主流版本。
 
   Java EE 切换到 Jakarta EE
 
  Spring Boot 3 开始,所有的 Java EE api 都需要迁移到 Jakarta EE 上来。
 
 
 
  这意味着原来项目中的 import 相关导入都要用 jakarta 替换 javax, 例如原来的 javax.servlet.Filter 要替换成 jakarta.servlet.Filter 。
 
  但是,有一些依赖 Java EE 的第三方库,目前还没有得到很好的支持,所以在 Spring Boot 3 中暂时会先移除这类组件的支持(比如: ehchache3, pooled jms等), 对于现有的 2.X 版本, M1 会有一些特性的缺失, Spring Boot 官方会在等这些第三方库发布 Jakarta 兼容库之后在重新引入。
 
  Java17 史上最快JDK, 它来了。
 
  Java 17 目前已经正式发布、它是继 Java 11 以来的首个长期支持版本。
 
  △Java各个版本生命周期
 
  Oracle 还提议将JDK LTS发布的节奏从每三年一次改为每两年一次,并且每个 LTS 版本的服务时间至少8年,Java版本通常是6个月已更新,时间分别在每年的3月到9月,而这些版本的支持时间基本在半年左右。
 
  移除了部分功能
 
  ## 移除了部分功能 
 
  - Apache ActiveMQ
 
  - Atomikos
 
  - EhCache2
 
  ## 未来计划
 
  后续 Sprng Boot 团队将会在每两个月发布一个新的里程碑版本,所以M2版本预计将在3月24日发布,而GA版本将在11月下旬和大家见面。
 
  卷,我们是专业的!
 
  在 Java 17 正式发布之前, Spring官方率先宣布,Spring Framework 6 和 Spring Boot 3 计划在 2022 年第四季度实现总体可用性的高端基线。
 
  Spring 以实现行动支持 Java17, 间接呼吁所有的Java开发工程师们,是时候该选择 Java 17 了。
 
  卷,我们是专业的!